IPv6 Static Tunnel IPv6IP


This form of tunneling is practically the same as it is with the IPv6 GRE and from the end host perpspective this does not make any difference however if you were doing a large scale bandwidth over the tunnel you would want to pick IPv6IP. The only difference is that it uses a different protocol number 41 (GRE uses 47) and it is a little bit less overhead in the encapsulation also another reason why I’m mentioning this is because it depends on how they formulate the question in the IPV6 section of your lab so simply be aware !

Untitled

This is how it is presented to us in GNS3

ipv6_gns_topology

GNS3 net file and all initial configs files you can find under : GREIPv6

Configuration wise it requires only one small change to the tunnel interfaces on both sides !

===============================================================

Tunnel protocol/transport IPv6/IP
Protocol = 41 (IPv6IP Header)

R6
interface Tunnel56
no ip address
ipv6 address 2001:56::6/64
tunnel source Loopback0
tunnel destination 150.28.5.5
tunnel mode ipv6ip
ipv6 rip 1 enable

or remove ipv6 rip 1 enable from tunnel interfaces and replace with IPv6 static route
ipv6 route  2001:155:28::/48 tunnel 56

R5
interface Tunnel56
no ip address
ipv6 address 2001:56::5/64
tunnel source Loopback0
tunnel destination 150.28.6.6
tunnel mode ipv6ip
ipv6 rip 1 enable

or remove ipv6 rip 1 enable from tunnel interfaces and replace with IPv6 static route
ipv6 route  2001:155:28::/48 tunnel 56

 

===============================================================

This one I’m going to mentioned in both posts IPv6 Static Tunnels – GRE and IPv6IP

Tunnel protocol/transport GRE/IPv6 (GRE over IPv6)
 Transport protocol is IPv6 hence tunnel source and tunnel destination is IPv6
 Protocol = 47 (GRE Header)
 Used for tunneling IPv4 over IPv6

R6
interface Tunnel56
ip address 56.56.56.6 255.255.255.0
tunnel source Loopback0 (loopback must be IPv6 address)
tunnel destination 2001:155:28:67::6
tunnel mode gre ipv6

R5
interface Tunnel56
ip address 56.56.56.6 255.255.255.0
tunnel source Loopback0 (loopback must be IPv6 address)
tunnel destination 2001:155:28:58::5
tunnel mode gre ipv6

===============================================================

 

Enjoy !

Tom

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: