IPv6 Static Tunnel GRE


Hi All,

Before I begin I want to say that I feel like I have never been closer to obtaining my CCIE number ! Everytime I revise one of the required for the lab exam technology it all becomes so logical and I’m just sitting the thinking “why did I have problem understanding this before?” 🙂

It has been a very long journey and I’ll do my best in August to end it so I can start concentrating on another track !

They say “once you’ve passed one it then is so much easier to pass another one” 🙂

Ok so IPv6 tunneling! I’m sure we all know why we need to know how to tunnel IPv6 over IPv4 and vice versa especially now when companies have already started migrating to IPv6 !

The first one is tunnling IPv6 over IPv4 in order to connect two IPv6 domains together so build below lab using the .net.file and initial configs to match the INE network

Untitled

This is how it is presented to us in GNS3

ipv6_gns_topology

GNS3 net : ipv6_net_file

Initial configs : ipv6_initial_conf_alldevices

So R5 and R6 each have loopback interfaces Loo5 and Loo6 respectively and these loopbacks are the IPv6 domains we need to connect together. Vlan 146 and Frame Relay are IPv4 only domains so basically to make it easier :

R5 is office A – connects with IPv4 to the internet and runs IPv6 (IPv6 RIP 1)on the LAN site
R6 is office B – connects with IPv4 to the internet and runs IPv6 (IPv6 RIP 1)on the LAN site
Vlan 146 and Frame Relay is the internet.

R5 and R6 LAN site you can any IGP you wish as long as the process matches on the tunnel interface and the remote site as otherwise you will need to do some form of redistribution.

Obviuosly without some sort of form of tunneling office A and office B will now be able to communicate with eachother what boils down to people screaming at you that they need to download some important files from the remote office and they can not ! Fix it ! 🙂

Static GRE tunnel

Default encapsulation is GRE/IP (GRE over IPv4)
Transport protocol is IPv4 hence tunnel source and tunnel destination is IPv4
Protocol = 47 (GRE Header)
Used for tunneling IPv6 over IPv4

R6
interface Tunnel56
no ip address
ipv6 address 2001:56::6/64
tunnel source Loopback0
tunnel destination 150.28.5.5
ipv6 rip 1 enable

or remove ipv6 rip 1 enable from tunnel interfaces and replace with IPv6 static route
ipv6 route  2001:155:28::/48 tunnel 56

R5
interface Tunnel56
no ip address
ipv6 address 2001:56::5/64
tunnel source Loopback0
tunnel destination 150.28.6.6
ipv6 rip 1 enable

or remove ipv6 rip 1 enable from tunnel interfaces and replace with IPv6 static route
ipv6 route  2001:155:28::/48 tunnel 56

=====================================================

This one I’m going to mentioned in both posts IPv6 Static Tunnels – GRE and IPv6IP

Tunnel protocol/transport GRE/IPv6 (GRE over IPv6)
Transport protocol is IPv6 hence tunnel source and tunnel destination is IPv6
Protocol = 47 (GRE Header)
Used for tunneling IPv4 over IPv6

R6
interface Tunnel56
ip address 56.56.56.6 255.255.255.0
tunnel source Loopback0 (loopback must be IPv6 address)
tunnel destination 2001:155:28:67::6
tunnel mode gre ipv6

R5
interface Tunnel56
ip address 56.56.56.6 255.255.255.0
tunnel source Loopback0 (loopback must be IPv6 address)
tunnel destination 2001:155:28:58::5
tunnel mode gre ipv6

=====================================================

Go ahead , set it up in your GNS3 and see what happens !

As I’ve run out of time this weekend so 6to4 and ISATAP I will post some time next week !

 

Enjoy !

Tom

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

One Response to IPv6 Static Tunnel GRE

  1. Pingback: IPv6 Static Tunnel IPv6IP | Tom G CCIE Blog

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: