PPPOE mandatory basic config with LOCAL pool and DHCP pool


Hello !

Some of you already know that I will attempting CCIE R&S lab exam in Brussels on the 23rd of August this years which means in  less then 3 months from now and believe me what I’m doing at the moment you can even call it studying , it is more like a torture at least it feels that way , still feeling positive though 🙂

I have been revising a lot of IPV6 recently and was hoping to post some configs about the different IPV6 tunnels but as I was going through the CCIE blueprint I realised that PPPOE can be one of those things that if you don’t know how to set it up then you will need to start looking in up in the DocCD which I’m sure we can all agree is definitely not so eye friendly unless of course you’ve been studying it for a long time and know the location of every topic which is not the case for most people I work with and of course myself.

So I’m simply trying to save you some time during your lab attempt and quickly show you what components you need to set this up in case you are asked to do it also there’s one of those things in life that if you don’t study for it you will most definitely get it on your lab and vice versa if you do study for it really hard then you will not.

I have been using most INE and IPExpert for my CCIE and the below set up is a small section of the INE CCIE lab the one you can find at R&SLAB where I also posted how to build it in GNS3.

I basically removed all devices and :
Left R3,R5 (both needed for our current config)
Left SW1 (no needed but I’ve included it so the set up looks more real)
Left Frame-Switch (not needed but it’s there to show you what I did if you look at the INE lab , you don’t even have to power it up)

Not relevant to this post but this is how the switch is set up

SWITCH
vlan 35

interface FastEthernet1/3
switchport mode access
switchport access vlan 35

interface FastEthernet1/5
switchport mode access
switchport access vlan 35

pppoe

I am sure that some of you will agree with me that the PPPOE although it is not that hard it can get simply confusing and it’s really easy to miss out one or two commands and then spend half hour trying to fix it.

Ok below is the minimum configuration you will need in order to make PPPOE operational also I was not able to find anything thorough enough on the internet so that’s why I decided to create this post.

PPPOE with the LOCAL pool without authentication

CLIENT R3

interface FastEthernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1

SERVER 5

interface FastEthernet0/0
no ip address
pppoe enable group PPPOE

ip local pool R3 155.1.35.3

interface Virtual-Template1
ip address 155.1.35.5 255.255.255.0
peer default ip address pool R3

bba-group pppoe PPPOE
virtual-template 1

TEST

R3#sh ip int br | ex un
Interface                  IP-Address      OK? Method Status                Protocol
Dialer1                    155.1.35.3          YES IPCP           up                    up

 

==============================================================
==============================================================

PPPOE with the LOCAL pool with authentication – R5 will authenticate R3

CLIENT R3

interface FastEthernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
ppp chap hostname R3PPP
ppp chap password CISCO

 

 

SERVER R5

username R3PPP password CISCO

interface FastEthernet0/0
no ip address
pppoe enable group PPPOE

ip local pool R3 155.1.35.3

interface Virtual-Template1
ip address 155.1.35.5 255.255.255.0
peer default ip address pool R3
ppp authentication chap PPPOE

bba-group pppoe PPPOE
virtual-template 1

 

 

==============================================================
==============================================================

PPPOE with the DHCP pool without authentication

CLIENT R3

interface FastEthernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
ip address dhcp
encapsulation ppp
dialer pool 1

 

 

SERVER R5

ip dhcp pool PPPOE
network 155.1.35.0 255.255.255.0

interface FastEthernet0/0
no ip address
pppoe enable group PPPOE

ip local pool R3 155.1.35.3

interface Virtual-Template1
ip address 155.1.35.5 255.255.255.0

bba-group pppoe PPPOE
virtual-template 1

 

 

TEST

On R3 you should see a console message saying

*Mar  1 00:50:50.495: %DHCP-6-ADDRESS_ASSIGN: Interface Dialer1 assigned DHCP address 155.1.35.1, mask 255.255.255.0, hostname R3

Different date though 🙂

 

 

 

==============================================================
==============================================================

PPPOE with the DHCP pool with authentication – R5 will authenticate R3

CLIENT R3

interface FastEthernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1

interface Dialer1
ip address dhcp
encapsulation ppp
dialer pool 1
ppp chap hostname R3PPP
ppp chap password CISCO

 

 

CLIENT R5

username R3PPP password CISCO

ip dhcp pool PPPOE
network 155.1.35.0 255.255.255.0

interface FastEthernet0/0
no ip address
pppoe enable group PPPOE

interface Virtual-Template1
ip address 155.1.35.5 255.255.255.0
ppp authentication chap PPPOE

bba-group pppoe PPPOE
virtual-template 1

==============================================================
==============================================================

You can configure R3 to authenticate R5 and set up pap or eap but this is just so you know what are the crucial components to make PPPOE work

 

Enjoy !
Tom

 

 

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: