NAT with match-host keyword


NAT_EXTEHello !

Say you acquired inside global IP address range of 200.2.2.1 – 200.2.2.5 /24 from your ISP and you need to ensure that IP addresses in network 10.1.1.0/24 are translated to these IPs but also you must ensure that the Inside Local IP addresses range 10.1.1.1 – 10.1.1.5 /24 match the host portion of the Inside Global range 200.2.2.1 – 200.2.2.5 /24

Please see the config for R1 which is our company’s internet facing device :

interface Loopback0
ip address 10.1.1.1 255.255.255.0
ip nat inside

interface Serial1/0.12 point-to-point
ip address 131.1.12.1 255.255.255.0
ip nat outside
ip virtual-reassembly in
frame-relay interface-dlci 102

Rack6R1(config)# access-li 10 per ho 10.1.1.1
Rack6R1(config)# access-li 10 per ho 10.1.1.2
Rack6R1(config)# access-li 10 per ho 10.1.1.3
Rack6R1(config)# access-li 10 per ho 10.1.1.4
Rack6R1(config)# access-li 10 per ho 10.1.1.5

ip nat pool LOO 131.1.12.11 131.1.12.15 netmask 255.255.255.0 type match-host

ip nat inside source list 10 pool LOO

 

Then when you start an ICMP ping from R1

IP address 10.1.1.1 will always translate to 131.1.20.11
IP address 10.1.1.2 will always translate to 131.1.20.12
IP address 10.1.1.3 will always translate to 131.1.20.13
IP address 10.1.1.4 will always translate to 131.1.20.14
IP address 10.1.1.5 will always translate to 131.1.20.15

 

Enjoy !

Tom

 

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: