CCIE GNS3 Topology


ccie_gns3_topology_new

This post is dedicated to the best practise for setting up CCIE R&S lab and I want to show you how to set up a practise rack to where you will never ever have to switch a single cable again , no matter what your lab topology looks like , the set up that does it all !

The only difference between this one and the previous topology is that I have changed the symbols so it’s easier to differentiate devices on screen but except for that it is all the same and no other changes have been made. Further down I have added initial configs files for CBT Nuggets CCIE series, INE , IP Expert and Narbik (Super Lab)

CCIE R&S topology I have built and been using on GNS3 for the CCIE journey.

So far I have seen and used topologies with a GNS3 built in Frame Relay switch plus 6 routers (INE spec) so I’ve decided to create one with CLI configurable Frame Switch and connect all devices in a way so that you are able to create any topology without the need of changing the cabling etc … The reason for 17 devices being used is because some of the CCIE preparation series like IP Expert, CCIE Service Provider see image   have topologies with more than 6 routers which is expectable from Cisco in the current v4 Lab exam but the idea is so we can practise not only INE lab scenarios with 6 routers but also IP Expert lab scenarios where Quadruple CCIE Scott Morris uses topology with 9 routers instead and of course for us to become more familiar with the actual frame relay switch configuration.

In case you having some issues with connectivity or the gns3 is crashing just after you start the topology, change the (127.0.0.1 with localhost) or vice versa in the .net file.

Please remember, that you can’t run most of layer 2 technologies command, since GNS3 (and all emulators) just do the software, where switches are mostly ASIC programmed to run the features.

This topology is customizable which means that with a little tweaking (vlans, ip addreses, frame switch config etc…) you will be able to practise any R&S scenario you can possibly find out there.

Firstly power up the 4 switches and copy and paste ccie_all_vlans . It will set you up for each of the below lab.
See intial configs below – INE lab specification VOL1

Frame_switch   BB1   BB2   BB3   R1   R2   R3   R4   R5   R6   SW1   SW2   SW3   SW4

ine_rns

See intial configs below – IP Expert lab specification VOL1

FRAME_SWITCH   BB1   BB2   BB3   SW1   SW2   SW3   SW4   R1   R2   R4   R5   R6   R7   R8   R9

ipexpert_r&s

See intial configs below – CBT Nuggets lab specification (CCIE R&S LAB SERIES)

CBT_BB1   FRAME_SWITCH_CBT   CBT_SW1   CBT_SW2   CBT_SW3   CBT_SW4

CBT_R1  CBT_R2   CBT_R3   CBT_R4   CBT_R5   CBT_R6   CBT_R7

cbt_rns

See intial configs below – Narbik Super Lab specification (CCIE R&S LAB SERIES)

SW1 – SW2 – SW3 – SW4
vlan data
vlan 111
vlan 112
vlan 113
vlan 3
apply
exit

NAR_SW1  NAR_SW2  NAR_SW3  NAR_SW4

NAR_R1  NAR_R2  NAR_R3  NAR_R4  NAR_R5  NAR_R6

NAR_BB1  NAR_BB2  NAR_BB3  NAR_FRAME_SWITCH

ccie_lab_narbik

See below GNS3 net file. Simply go to previously specified by you GNS projects folder on your hard drive , right click on a net.file , edit network file , copy/paste the output from the one provided below ,change the image path to the path directory where you store your IOS images and change the workingdir path pointing to wherever you have saved provided above configs , save it the net.file under another name to avoid removing some of your own by mistake and there you have your CCIE topology. Launch GNS3 , literally copy and paste one of the provided above configs depending of course on what series you are watching at the time and start labbing !

CCIE_GNS_NET_FILE

I have not been able to upload actual GNS3 file however I personally always take above approach or literally build a topology from scratch cause then you know what exact settings you need to set on your machine , idle pc etc … and most importantly your mind visually memorizes connectivity between devices. Simply try an approach as if you were sitting at the CCIE lab exam, read the net.file and subconsciously make a mental picture of the topology.

If you’re already in possession of the INE , IP Expert Workbooks , CBT Nuggets CCIE or Narbik video series then these initial config files will save you at least 1.5hrs of labbing if not more!

Please go ahead and check on youtube @

http://www.youtube.com/watch?v=wluKh57FAnM

Enjoy!

All the best !

Tom

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

76 Responses to CCIE GNS3 Topology

  1. linuxer says:

    Reblogged this on therouters.

  2. Seb says:

    Excellent ! just tested it and it works perfectly
    thanks mate

    • abbas says:

      Dear can u tell how can i download this file unable to find

    • azeezseth says:

      Hi Tom,

      I am just started my CCIE study and I downloaded CCIE_GNS_NET_FILE and edited but still I am not able to fire the topology …looks me I am wrong in doing this so…can please explain how I can fire this topology.

      • ccie4all says:

        Hello Azeezseth,

        Apologize for the late reply, too much networking to do 🙂

        Basically the best way to set it all up is to build the topology from scratch using the net file and the reason is that whenever you build a lab in GNS3 it then chooses best values and variables for your PC which in most cases mean that it’ll use a different set of values for another PC and so on therefore the best is to build your lab from scratch using the NET_FILE.

        Please go ahead and shout if anything !

        Cheers
        Tom

  3. ccie4all says:

    Very happy I can be of help to all of you!

    • abbas says:

      Dear can u tell how can i download this file unable to find

  4. mooray says:

    Super mate ! all working as expected!
    Best CCIE topology so far out there !

  5. Pingback: 2012 in review « Tom Giembicki's CCIE Blog

  6. Pingback: OSPF LSAs and Area Types « Tom Giembicki's CCIE Blog

  7. Dave IT guy says:

    I’m in the process of starting my journey from CCNP to CCIE R&S, I like the idea of having a lab in GNS3 and have used it for the CCNP Route exam. I’m checking into INE and IPexperts and wondering what labs can’t be done when only using GNS3?

    Great Site,
    Thank you,
    Dave

    • ccie4all says:

      Hi Dave,

      That’s great! Definitely go for it! Before I did my CCNP I thought to myself that’s it I’m not going to sit and study anymore and as soon as I opened INE and IPexpert workbooks I realised how wrong I was 🙂 This is simply an amazing journey !
      well, because Layer 2 switching is hardware based, which means switches use ASICs to build and maintain MAC address tables or CAM tables you will not be able to dive deep into L2. As you know GNS3 has an integrated L2 switch that supports VLANs with 802.1q trunking but it is just a basic virtual switch with very limited functionality.
      Basically unfortunately you will not be able to learn anything advanced that falls into Bridging and Switching but that’s about it! You may have to get a fairly recent IOS in order to practise a router Zone Based Firewall and PFR(Performance Routing) but this can be easily done.
      Of course an ideal scenario would be to purchase 2x 3500 and 2x 3560 switches and connect then vie a cloud device to your GNS3 but I know the devices don’t come cheap.
      To cut long story short , concentrate as much as you can on L3, IP Routing, Redistribution (very tricky when you go deep) QOS etc … and try and borrow 4x L2 switches from work or set up a small lab in your workplace comms room if it’s possible and practise on your lunch breaks.
      This CCIE topology I have been using for a very long time and once you’ve set it up you will be able to practise literally ANYTHING that relates to CCIE R&S (except for advanced L2) and EVEN portions of CCIE SP.
      One last word , from my experience, L2 is very logical and if you’ve been in a networkking field for a while you will easily be able to pass this section on your R&S lab.
      Although look deep into spanning-tree 🙂

      All The Best
      Tom

      • Dave says:

        Great info Tom, thank you. I have another question/s. Can I do the switching part with the switches you mentioned (2×3550 and 2×3560) with out being connected to a router for the lab at work? If not what would do you think would be the least amount of equipment I could use for a CCIE rack at work for just the switching part and I could do the other CCIE lab training (INE or IPExperts) at home on GNS3?

        Thanks again,
        Dave

      • ccie4all says:

        You’re welcome !
        Of course without any probelms.
        I can only think of ONLY two cases where having those 4x switches it would be nice to have also 2x or 3x routers routers connected :
        1 – when you’d want to practise Mac access-list (different from normal ip access-lists) as cannot be applied to an IP traffic due to an ASIC switch architecture
        2 – and 802.1q Tunneling which I have covered in
        https://ccie4all.wordpress.com/2012/12/25/802-1q-tunneling/

        but then again these are not really complicated to learn and understand so yes GNS3 is without any doubt your best friend !

        cheers
        Tom

  8. Hello there, i have a question, im starting with the INE preparation for the CCIE labs… i notice that they offer configurations for BB1 BB2 and BB3, in this case using the BB1 as a frame relay switch, as i understand i can use a frame relay switch on gns3 or the configuration you uploaded… and just delete that part from the configuration on the BB1 file and that way i will have 2 separate devices and not frame relay + BB1 right? can i use your files for that porpuse? i hope i made my self clear.. thanks for sharking this info!!!

    • ccie4all says:

      Hello Lalo,

      Yes this is correct ! if only you have an opportunity to separate devices and have every single devices to perform on its own then of course go for that option as firstly that way it’ll be much easier to concentrate on configs and secondly it is highly unlikely that in real world you would have a router performing routing and frame relay switching at the same time.
      With the topology and configs I’ve uploaded you can easily build INE lab (use the net file) and simply copy and paste those basic config into each devices and you’re ready to go !
      Layer 2 section in INE workbooks may be a bit hard to learn due to GNS3 limited L2 switch functionality but all other chapters starting from the Frame Relay all the way down to the MPLS VPNs will be spot on !

      Enjoy !
      Tom

  9. Rhamie says:

    Hi Tom,

    Thanks the loads of info you have on this blog.
    I will like to know your view on the best way to go towards achieving the CCIE. I have my CCIP almost a year now and haven’t really practiced so much as my job hasn’t been so much involved with Cisco devices (rather more of Linux). Currently, I have the Cisco CCIE study guide and GNS3. Could you please provide the best approach towards achieving the CCIE R&S, written and the Lab.

    Thanks.

    • ccie4all says:

      Hi Rhamie,

      Just received your comment on the way from work! Massive thank you for this!
      Correct, without any doubt achieving CCIE status is not an easy job. I compare it to being back at Uni.
      I have been preparing myself for the past 20 months for R&S and I feel I’m almost ready to face it. I’m one of those guys who would like to pass this exam at the first attempt which is the reason why I still have not booked it, waiting for the right moment, few months and few more labs away 🙂
      I have followed one simple rule , having watched and listened a lot of INE and IPExpert guys, Brian McGahan, Brian Dennis, Scott Morris them saying “do not jump into all those technologies at once, focus on one, learn and understand it and then move on to the next one” is working for me.Every few weeks I go back to something I studied 4 months ago like I did this weekend with QOS to make sure I still have that knowledge.
      I take “notapad” notes whenever I find something not clear for instance Multicast, one of those frustrating topics for me 🙂
      I’m also using a very simple spreadsheet that covers every topic to track my hours (I’ll post the spreadsheet very soon)
      I’m sure I don’t have to tell you how many times I have thought to myself “that’s it I cant do this anymore” cause I’m sure you know the pain and fascination of studying Cisco, but to give up I feel it would be one of the biggest mistakes in my life which most definitely would turn into a regret in the future!
      Go for it !

      Tom

  10. ashwani says:

    I think Narbik ( Micronics Training) matters more than CBT Nuggets in CCIE training.

    So the third topology and initial configs should be for his workbook.

    • ccie4all says:

      Hi Ashwani,

      Very good point !! As soon as I’m more free I will try and gather some topology materials from my work colleagues and will most definitely look into this.

      Thanks so much !
      Tom

  11. Pingback: CCIE TSHOOT LAB « Tom Giembicki's CCIE Blog

  12. dadaenoo says:

    Hi Tom,

    Thanks for your blog/tips and information related to ccie studies. I’m going for my number. I’m aiming to do it in one hit and taking the a year and half to study for it (hard to get but not impossible). Any helpful info to help with studies do provide them. I’m looking at ine materials to do my main studies and supplement it with others. I will simulate your gns topologies and practice with them. Thanks.

    • ccie4all says:

      Hello Dadaenoo,

      That is really great !
      For the past 12 months I’ve had no social life and without any doubt this is not an easy road also have the same goal to pass on first attempt !
      I have been using both INE and IPExpert and must say that their material is more than enough to pass this exam.

      Best
      Tom

      • Dadae says:

        Thanks Tom, it is good to hear from you. I’m in the process of gathering materials etc. I have read the “Your CCIE Lab Success Strategy: The Non-Technical Guidebook” by Vivek and Dean to be aware of how to do this right. I love studying and this brings me back to my university studies so I’m looking forward to it. Its exciting and thanks for your valuable contributions:-). Will be visiting your blog regularly and good luck with your upcoming test.

  13. Pingback: CCIE R&S FULL LAB | Tom G CCIE Blog

  14. Jon K says:

    I am sure glad that I subscribed to your blog, Tom. While it might be sometime till I get to the CCIE level in order to fully utilize your labs, it’s still really cool to read about them as well as what others think. Thanks again!

    • ccie4all says:

      Hello Jon !

      This is really amazing to hear and I’m very happy I can provide all the labs and other info that I’m using for my Lab exam !
      I will be keep positing new materials and resources cause at the end of the day we all want the same thing , the most important “number” in the world !

      Thanks so much !
      Tom

  15. Ian says:

    Asking questions are genuinely good thing if you are not understanding something entirely, however this paragraph presents nice
    understanding even.

  16. Pingback: Tuning BGP Attributes | Tom G CCIE Blog

  17. karim says:

    Hello,

    where is config file of R3 for architecture ip expert Lab?

    • ccie4all says:

      Hello Karim,

      IPexpert offers three separate workbook designed to assist us with CCIE (R&S) 4.0 lab preparation and strangly enough they decided not to use R3 in any of their recent CCIE R$S workbooks so basically if you’re in possession of ipexpert ccie workbooks this gns3 topology is all you need

      Best
      Tom

  18. Clement says:

    I am in africa. Equipment is not easy to get.
    I managed to get GNS3 with a breakout switch working.
    Am using a 3560G(Employers old stock) as a breakout switch and it supports layer 2 tunneling(CDP STP) works.
    Your INE topology has come in handy kudos for that.
    I have 3×3550 and 2x3560G.
    My INE & IPexpert materials.
    Anyone sharing.
    I want to get my number on 1st attempt cannot afford to do this more than once.

    • ccie4all says:

      Hi Clement,

      Glad that my topology is helping you! My intension was to build it once and do not touch it unless it is absolutely necessary.
      I literally hope for the same to get my number on first attempt but I know from people (already CCIE) it won’t be easy. So far the best video series I’ve come across is the new INE CCIE Advanced Routing & Switching series where Brian McGahan deeply explains each main technology and other expected on the exam IP services.
      According to Brian you do need to know L2 and L3 inside out but not necessarily be a guru of all ip services such as NTP,DNS,DHCP,NAT etc as long as you know where to locate these in the Cisco DOC CD which is available during the exam.
      Give us a shout if anything so we can exchange ideas etc …

      Best
      Tom

      • Clement says:

        Tom,

        Something i noticed is that R1 and R2 (INE) has identical config.
        Is this the way its supposed to be?

        Let’s keep up the work share ideas and conquer this.
        I have found INE to be good, however i have referenced BullDog bootcamp (CCNP-Switch).
        Books are a must and CCIP advanced routing & MPLS is good material though certification has been fazed out.

      • ccie4all says:

        Hi Clement !

        Great catch !! You are absolutely correct ! These two routers should have completely different configs and I have just corrected this mistake ! When you try and download it now it should be ok.
        Currently I’m revising all ip security services such as CBAC, ZBFW ,reflexsive access-list etc but according to INE you don’t have to be an expert in those specifically for the exam but you do have to know how to navigate to those sections in DOC CD.
        INE has been the best resource I’ve had however I’ve also used IPEXPERT just to get a different feel if you know what I mean.
        Yip MPLS is a must these days on a CCIE Lab but the good thing is that the MPLS VPNs are not really that complicated to set up and understand on the other hand you never know what you are going to get on your lab 🙂

        Best
        Tom

  19. Pingback: INE CCIE ADVANCED BGP | Tom G CCIE Blog

  20. Mikeotuus says:

    Hello, I just finish downloading your materials and let me say this, I’m impressed with your work. And like you, I will like to get my number on my first attempt so I am taking it easy(but at a constant pace). Thanks for doing this for “us”. And I look forward to brain storming with you in the coming weeks and months ahead.

    • ccie4all says:

      Hello Mikeotuus!

      Great to hear I can be of help to you guys! My goal is also to pass on first attempt that’s why I’m giving myself few more weeks (first attempt sometime in august). I know people who took the lab 5 – 7 times (lots of wasted money) and I guess this is because they thought they “had” it and in the end they realised they did not so id rather be over-prepared then during the exam get stuck on one of the section !

      Best of luck mate !

      Cheers
      Tom

  21. JeremyRom says:

    It contains huge amount of information. Thank you for great posting. I like it.
    CCIE Rack Rental

    • ccie4all says:

      Hello JeremyRom,

      You’re more than welcome !
      More to come very soon !

      Best
      Tom

  22. Matt says:

    What does BB stand for, broad band?

    • ccie4all says:

      Hello Matt,

      In CCIE network / lab preparation world BB stands for Backbone , the external devices that the candidate does not have access to in the exam and does not configure , they’re basically there to inject routing information

      thanks!
      Tom

  23. Matt says:

    The one thing I regret is not making copious notes from my CCNP studies. I wish I had made a configuration guide and troubleshooting guide study sheet for each technology so I can glance at stuff at work. Has anybody made some good study sheets i.e., configuration mpls troubleshoot mpls. I have the white papers online but maybe something from the labs would be a builder of confidence even more so. Thanks.

  24. frogman says:

    Has anybody had some problem in GNS3 with C3700 not loading the configs after reloading the router. I have te latest version installed on Win7X64.

  25. Donny says:

    Hi ccie4all, I notice your GNS has serial1/3 and serial 1/1 for the frame-relay router. I would like to know which model of the router are you using to accomplish that as I am using a 3725 and it seems I could only have 6 serial interface (2x3WIC). Thanks in advance.

    • Donny says:

      Sorry, just saw the configuration file. Please ignore my question. 🙂

      • ccie4all says:

        Hello Donny,

        Glad you sorted it ! Please go ahead and ask if anything !

        Best Regards
        Tom

  26. VLAD says:

    Hello Guys,

    I’m having a problem when loading the .net file… GNS3 always says he cannot find the devices SW.
    Can anyone please send me the .net file???
    I don’t know if I changed everything I was suposed to. I changed the working directory and the image, but when i save the file with a .net extension it never loads the topology because he says he can’t find devices called SW. What am I doing wrong?

    Also… I think there are 3 topologys in the same file, and I can’t figure out where does one end and the other starts.

    Please Help!

    If you can send me the .net file and three different files for the 3 scenarios I would really apreciate it!!
    Please send to bateriasautosil@yahoo.com

    THANK YOU

  27. HBK says:

    Dear Tom,
    1. Is it possible that you include Narbriks Lab topology in this.
    2. Can you briefly explain what things I need to change in the .net file to make it work according to my IOS, etc.
    3. is this possible to use this topology with 2×3550 and 2×3560 real switches(Quad Nic Solution) and how would I connect them according to this topology.
    Thanks for the great work!!

    • ccie4all says:

      Hello HBK!

      1.Certainly! As soon as I managed to find some time I will definitely do. Narbik is a great CCIE instructor and of course except for the INE and IPExpert , Narbik workbooks is my 3rd choice!
      2. Basically if you build the topology from scratch, exact same way I’ve explained in the original post you will not have to change or do anything if however you have your own topology running on your PC then in order to match both of them you will need to change the:
      image=C:// directory path so your GNS3 devices where to look for an image
      model= which basically corresponds to the device model
      workingdir = and point it to practically any location on your hard drive so when you power up your topology the devices know where to look for all initial configs
      idlepc = change the value so your processor is able to handle smoothly the devices (and there’s a lot of them)

      Basically it’ll be much easier to build it from scratch. For the past 3 years I’ve only been using this particular one CCIE GNS3 Topology set up on my home PC/WORK because it is easy to manage and you can practically build and practise any scenario you can find on the internet, books , workbooks etc ….!

      3.Of course it is , all you have to do is get 2×3550 and 2×3560 switches and set them up as a breakout switch
      Below video from Steve Bowler is a great example of how to do this

      Best Regards
      Tom

      • HBK says:

        Dear Tom,
        I have managed to build the .net file. Thanks alot…
        Ok it means it wont work with Quad Nics…offcourse due to the lack of NIC card ports i guess 🙂

  28. HBK says:

    dEAR tOM,
    INE topology has no seperate FR Switch as BB1 Router is also acting as a FR Switch….Have you taken care of that ?? Also can you please make a Quad NIC version of this topology!! It will be extremely helpful!!! Have a good day

    • ccie4all says:

      Hello HBK,

      You are absolutely correct ! It is the way they have their lab set up however it’ll most definitely not be the case in the real CCIE lab and especially real world scenarios where evey device will be responsible to perform one function which is the reason why I’ve used every device to do its own magic however of course it can be done either way.
      Most definitely I will ! Once I’ve got some more time on my hands i will build and post another topology using real 2×3560 and 2×3550 switches.

      Best Regards
      Tom

  29. HBK says:

    Dear Tom,
    I have a query again. I have seen that with INE topology the interfaces names are different as we have in GNS3
    enable
    configure terminal
    ! rsrack1
    ! iewb.rs.vol1-v5.0-basic.ip.addressing
    ! r5
    ! Tue Nov 17 14:33:48 PST 2009
    ! Copyright (C) 2009 Internetwork Expert, Inc. — All rights reserved
    !
    hostname Rack1R5
    !
    enable password cisco
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 150.1.5.5 255.255.255.0
    !
    interface FastEthernet0/0
    no shutdown
    ip address 155.1.58.5 255.255.255.0
    no shutdown
    !
    interface FastEthernet0/1
    no shutdown
    ip address 155.1.5.5 255.255.255.0
    no shutdown
    !
    interface Serial0/0/0
    no shutdown
    ip address 155.1.0.5 255.255.255.0
    shutdown
    !
    interface Serial0/1/0
    no shutdown
    ip address 155.1.45.5 255.255.255.0
    no shutdown
    !
    ip classless
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    privilege level 15
    line aux 0
    exec-timeout 0 0
    privilege level 15
    line vty 0 4
    password cisco
    login
    !
    end
    end
    copy running-config startup-config

    . So i think simple copy and paste wouldnt work. Do you have any work around for that ???

    • ccie4all says:

      Hello HBK!

      You are absolutely correct! It is because of GNS3 device module limitations however all provided configs I have prepared are just for the GNS3 set up meaning that all ip addresses,interfaces etc have been pre-configured specifically for the GNS3 therefore once you’ve built your lab all you have to do is to download all configs and paste them into each device console and you’re ready to go !

      Best
      Tom

  30. HBK says:

    If you get some time please post a hybrid topology as I requested before. Most of the CCIE students are using this setup now a days and it would be beneficial for people like us.

    • ccie4all says:

      I totally agree , I am personally using the GNS3 topology from this post but with real switches connected to GNS using a breakout switch as otherwise it’d be almost impossible to learn and prepare yourself for the layer2 section in the real lab. As soon as I’m done with my Lab exam in Belgium I will make it available !

      Best!
      Tom

  31. HBK says:

    Dear Tom,
    Thanks for your quick reply I really appreciate it. Please dont mind my stupid questions as I have very recently begun my CCIE studies and at the moment I am setting up my lab with Quad Nics.
    The file you posted above are I think one of the many initial configs. I have 10 different folders with different topics of INE having different initial configs. Above I pasted the intial config from the INE folder “basic Ip addressing”. I havent started any workbooks yet as I told you before I am just going to start so my understanding is that as the workbooks goes they will ask me to load different sets of initial configs to play with. All of the different initial configs have interfaces like ser0/0/0 etc which we dont have on GNS3. So in this context I wanted to ask that how are u dealing with this issue?? Have you converted all of the initial configs for INE WB Vol 1 ??

    • ccie4all says:

      No problem at all ! Asking questions is the best way to become the best !
      The initial configs I posted are for the INE Vol 1. INE have released four different CCIE Volumes and each focuses on section throughout the CCIE journey however they are all related to Vol 1 in some form.
      For instance if you wish to practice INE labs from Vol4 all you have to do is in notepad prior to pasting the configs slightly change around some of the interfaces meaning if for the frame relay network on R5 they’re using S0/0/0 which cannot be accomplished with GNS3 due to device module limitation you simply change it to S0/0 which I believe is the interface I used in my topology and so on … the point is that you do not have to build a completely new lab from scratch as they one I created can match anything from INE all Volumes through CBT Nuggets , Narbik all the way up to IPExpert where they use 9 routers instead of 6 , create some new vlans on each switch depending on the lab requirements and the Lab Volume you’re doing at that’s all !

      The trick is = before you copy and paste the config make some small changes to the interfaces in notepad

      Hope this helps !
      Best
      Tom

  32. HBK says:

    Thanks alot Tom,
    I will be in touch with you and my best wishes for your studies and for your lab exam 🙂

  33. Richie says:

    Hi mate

    Really like the look of this and have the topology up and running can I just ask a couple of questions to go with the 600 you’ve already answered lol

    – Why use the 3745 ? (gns3 complains about a bug with saving startup config)
    – I have an issue with GNS3 loading the startup configs into the devices although this maybe to do with the above have you noticed the same ? Is that why you recommend copy and paste ?
    – With the topology have you modified the initial configs to match the topology you are using ?
    – Its maybe worth mentioning aswell that the vlans have to added to the database when you copy the configs in.

    Thanks again . This has been a great help since I lost my physical switches.

    • Richie says:

      The 3725 in GNS3 dont have the issue with loading the startup config. I assume this is a 3745 thing.

      Is there a particular benefit elsewhere to using the 45 ?

      • ccie4all says:

        Correct ! There’s been an ongoing issue with GNS3 3745 IOS however 3725 would be more than enough for CCIE R&S preparation !

        Best
        Tom

    • ccie4all says:

      Hey Richie !

      First of all , apologize for the late reply ! Busy at work ! 🙂

      – Why use the 3745 ? (gns3 complains about a bug with saving startup config) —> except for the few additional features on 3745 vs 3725 such as “Support for the Cisco Intrusion Detection System (IDS)” , “Support for IP communications voice/fax network modules” etc there’s nothing more to it so of course 3725 will be more than sufficient for R&S
      – I have an issue with GNS3 loading the startup configs into the devices although this maybe to do with the above have you noticed the same ? Is that why you recommend copy and paste ? —> Correct! I myself hardly ever save the config in GNS3 due to the reason you’ve described and 99% of the time I simply copy and paste !
      – With the topology have you modified the initial configs to match the topology you are using ? —> Correct ! When you load the lab and copy and past the initial configs into each device , it’ll match INE,IP expert or CBT CCIE series, there may be a small difference with some interfaces because of GNS3 device module limitations but that’s about it !
      – Its maybe worth mentioning aswell that the vlans have to added to the database when you copy the configs in —> Good point ! Will update as soon as I can !

      You’re more than welcome and please shout if anything !

      Best
      Tom

      • Richie says:

        Thanks for getting back to me did you ever think of a way to keep those vlans in the config ?

      • ccie4all says:

        hi Richie,

        Just updated the post !

        Best
        Tom

  34. Richie says:

    Ah nice I see it.

    Dont know how much info you want to give but mentioning the erase flash for the guys who cant create vlans after starting the topology.

    Also the site may have an issue with emails being sent on posts you are following. I don’t seem to be getting any even though I follow the post.

    You got any other way of being contacted other than the blog email twitter etc ?

  35. Richie says:

    Also find myself struggling with another problem in the topology or I assume gns3 as a whole.

    Between the 4 switches you cant ping the ips, layer 2 is fine but theres no layer 3 between them. No arp responses comeback and even adding in statics doesnt solve it. Remove all the layer 2 links and it works.

  36. Soufiane says:

    Where is the link to download the topology please ?

    • ccie4all says:

      hi Soufiane,

      The easiest way to do this at the moment is to “save a picture as” but will soon include the link and add more extras etc…

      Cheers
      Tom

  37. Roger McBreaker says:

    The Narbik Frame switch seems to be missing some config

  38. Pingback: OSPF LSAs and Area Types | Journey Begins...

  39. Richie says:

    Not sure of you still maintain this but did you ever come across the issue with packet lose and encapsulation failures between some devices ?

  40. khizer says:

    can u create a topology with IOUs for all the vendors….

  41. Mario Palma says:

    Hi CCIE4all,
    Could you please post the .NET file for GNS3 v1.3.1?

    Thanks.

  42. Pingback: OSPF LSAs and Area Types - ..::Nothing special blog::..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: