EIGRP Load Balancing


• Review basic EIGRP configuration
• Explore the EIGRP topology table
• Learn to identify successors, feasible successors, and feasible distances
• Learn to use debug commands for EIGRP’s topology table
• Configure and verify equal-cost load balancing with EIGRP
• Configure and verify unequal-cost load balancing with EIGRP

As a senior network engineer, you are considering deploying EIGRP in your corporation and want to evaluate its ability to converge quickly in a changing environment. You are also interested in equal-cost and unequal-cost load balancing, because your network is filled with redundant links. These links are not often used by other link-state routing protocols because of high metrics. Since you are interested in testing the EIGRP claims that you have read about, you decide to implement and test on a set of three lab routers before deploying EIGRP throughout your corporate network.
Step 1: Addressing and Serial Configuration
Create three loopback interfaces on each router and address them 10.1.X.1/30, 10.1.X.5/30, and 10.1.X.9/30, where X is the number of the router

R1(config)# interface Loopback 11
R1(config-if)# ip address 10.1.1.1 255.255.255.252
R1(config-if)# exit
R1(config)# interface Loopback 15
R1(config-if)# ip address 10.1.1.5 255.255.255.252
R1(config-if)# exit
R1(config)# interface Loopback 19
R1(config-if)# ip address 10.1.1.9 255.255.255.252
R1(config-if)# exit
!
R2(config)# interface Loopback 21
R2(config-if)# ip address 10.1.2.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface Loopback 25
R2(config-if)# ip address 10.1.2.5 255.255.255.252
R2(config-if)# exit
R2(config)# interface Loopback 29
R2(config-if)# ip address 10.1.2.9 255.255.255.252
R2(config-if)# exit
!
R3(config)# interface Loopback 31
R3(config-if)# ip address 10.1.3.1 255.255.255.252
R3(config-if)# exit
R3(config)# interface Loopback 35
R3(config-if)# ip address 10.1.3.5 255.255.255.252
R3(config-if)# exit
R3(config)# interface Loopback 39
R3(config-if)# ip address 10.1.3.9 255.255.255.252
R3(config-if)# exit

==========================

Address the serial interfaces with the addressing shown in the topology diagram. Set the clock rate to 64 kbps, and manually configure the interface bandwidth to 64 kbps.
R1(config)# interface Serial 0/0/0
R1(config-if)# description R1–>R2
R1(config-if)# clock rate 64000
R1(config-if)# bandwidth 64
R1(config-if)# ip address 10.1.102.1 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface Serial 0/0/1
R1(config-if)# description R1–>R3
R1(config-if)# bandwidth 64
R1(config-if)# ip address 10.1.103.1 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit

R2(config)# interface Serial 0/0/0
R2(config-if)# description R2–>R1
R2(config-if)# bandwidth 64
R2(config-if)# ip address 10.1.102.2 255.255.255.248
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface Serial 0/0/1
R2(config-if)# description R2–>R3
R2(config-if)# clock rate 64000
R2(config-if)# bandwidth 64
R2(config-if)# ip address 10.1.203.2 255.255.255.248
R2(config-if)# no shutdown
R2(config-if)# exit

R3(config)# interface Serial 0/0/0
R3(config-if)# description R3–>R1
R3(config-if)# clock rate 64000
R3(config-if)# bandwidth 64
R3(config-if)# ip address 10.1.103.3 255.255.255.248
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface Serial 0/0/1
R3(config-if)# description R3–>R2
R3(config-if)# bandwidth 64
R3(config-if)# ip address 10.1.203.3 255.255.255.248
R3(config-if)# no shutdown
R3(config-if)# exit

==========================

EIGRP Configuration
Now set up EIGRP AS 100 using the same commands you used in the first EIGRP lab.

Use the debug ip eigrp 100 command to watch EIGRP install the routes in the routing table when your routers become adjacent. We will examine what is occurring behind the scenes in the next step.
For your reference, these are the commands:
R1(config)# router eigrp 100
R1(config-router)# network 10.0.0.0
!
R2(config)# router eigrp 100
R2(config-router)# network 10.0.0.0
!
R3(config)# router eigrp 100
R3(config-router)# network 10.0.0.0

Once you have full adjacency between the routers, ping all the remote loopbacks to ensure full connectivity, or use the following TCL script. If you have never used TCL scripts before or need a refresher, see the TCL lab in the routing module.
foreach address {
10.1.1.1
10.1.1.5
10.1.1.9
10.1.2.1
10.1.2.5
10.1.2.9
10.1.3.1
10.1.3.5
10.1.3.9
10.1.102.1
10.1.102.2
10.1.103.1
10.1.103.3
10.1.203.2
10.1.203.3
} { ping $address }
You get ICMP echo replies for every address pinged

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: