RIP Route Metric Offset-Lists


hostname R1
!
interface Loopback0
ip address 10.70.10.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.122 point-to-point
ip address 10.70.12.1 255.255.255.252
frame-relay interface-dlci 122
!
interface Serial0/1
ip address 10.70.21.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
!
exit
!
router rip
no auto-summary
version 2
network 10.0.0.0
timers basic 30 40 10 60
passive-interface serial0/1
neighbor 10.70.21.2

hostname R2
!
interface Loopback0
ip address 10.70.20.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.221 point-to-point
ip address 10.70.12.2 255.255.255.252
frame-relay interface-dlci 221
ip rip triggered
ip rip send version 1 2
ip rip receive version 1 2
!
interface Serial0/0.223 point-to-point
ip address 10.70.23.1 255.255.255.252
frame-relay interface-dlci 223
!
interface Serial0/1
ip address 10.70.21.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
clock rate 128000
no shut
exit
!
router rip
no auto-summary
version 2
network 10.0.0.0
timers basic 30 40 10 60
passive-interface serial0/1
neighbor 10.70.21.1

hostname R3
!
interface Loopback0
ip address 10.70.30.1 255.255.255.0
!
interface Loopback103000
ip address 10.30.0.1 255.255.255.0
!
interface Loopback103010
ip address 10.30.1.1 255.255.255.0
!
interface Loopback103020
ip address 10.30.2.1 255.255.255.0
!
interface Loopback103030
ip address 10.30.3.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
no ip split-horizon
!
interface Serial0/0.322 point-to-point
ip address 10.70.23.2 255.255.255.252
frame-relay interface-dlci 322
ip rip advertise 10
ip rip triggered
ip rip send version 1 2
ip rip receive version 1 2
ip summary-address ip 10.30.0.0 255.255.252.0
!
router rip
no auto-summary
version 2
network 10.0.0.0
timers basic 30 40 10 60
default-information originate

Configure a standard named access list called RIP_BACKUP_OFFSETand permit any traffic.

R1>enable
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip access-list standard RIP_BACKUP_OFFSET
R1(config-std-nacl)#permit any
R1(config-std-nacl)#end
R1#

Objective 2. – Configure an offset-list on R1 to increase the metric by 2 hops from any routes advertised or learned on interface Serial0/1.

R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#offset-list RIP_BACKUP_OFFSET in 2 Serial0/1
R1(config-router)#offset-list RIP_BACKUP_OFFSET out 2 Serial0/1
R1(config-router)#end
R1#

Verify your configuration by viewing the routing table on both R1 and R2.
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.70.12.2 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 8 subnets, 4 masks
R       10.30.0.0/22 [120/2] via 10.70.12.2, 00:00:04, Serial0/0.122
C       10.70.12.0/30 is directly connected, Serial0/0.122
C       10.70.10.0/24 is directly connected, Loopback0
R       10.70.30.0/24 [120/2] via 10.70.12.2, 00:00:04, Serial0/0.122
R       10.70.20.0/24 [120/1] via 10.70.12.2, 00:00:04, Serial0/0.122
C       10.70.21.0/30 is directly connected, Serial0/1
R       10.70.23.0/30 [120/1] via 10.70.12.2, 00:00:05, Serial0/0.122
C       10.70.21.2/32 is directly connected, Serial0/1
R*   0.0.0.0/0 [120/2] via 10.70.12.2, 00:00:05, Serial0/0.122
R1#

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.70.23.2 to network 0.0.0.0

     10.0.0.0/8 is variably subnetted, 8 subnets, 4 masks
R       10.30.0.0/22 [120/1] via 10.70.23.2, 00:00:01, Serial0/0.223
C       10.70.12.0/30 is directly connected, Serial0/0.221
R       10.70.10.0/24 [120/1] via 10.70.12.1, 00:00:06, Serial0/0.221
R       10.70.30.0/24 [120/1] via 10.70.23.2, 00:00:01, Serial0/0.223
C       10.70.21.1/32 is directly connected, Serial0/1
C       10.70.20.0/24 is directly connected, Loopback0
C       10.70.21.0/30 is directly connected, Serial0/1
C       10.70.23.0/30 is directly connected, Serial0/0.223
R*   0.0.0.0/0 [120/1] via 10.70.23.2, 00:00:02, Serial0/0.223
R2#

As shown from above; the IP routing tables of R1 and R2 are no longer load balancing traffic using the frame-relay network and the point-to-point backup T1.

Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: