EIGRP neighbor discovery


  • Discovery your EIGRP neighbour autonomous system . Our simple simple simple topology 🙂 but watch out for these type of questions on the exam cause they’re the tricky ones

EIGRP neighbor discoveryThis is R9 interfaces

  • R9#sh ip int br | ex un
  • Interface                  IP-Address      OK? Method Status                Protocol
  • FastEthernet0/0            100.100.250.9   YES NVRAM  up                 up
  • FastEthernet0/1            150.100.91.9    YES NVRAM  up                    up
  • Serial1/2                         150.100.69.9    YES NVRAM  up                    up
  • Loopback0                       200.0.0.9       YES NVRAM  up                     up

And BB3

  • BB3(config-if)#do sh ip int br | ex un
  • Interface                  IP-Address      OK? Method Status                Protocol
  • FastEthernet0/0            100.100.250.250 YES NVRAM  up                up
  • Loopback0                      100.100.251.250 YES manual up                    up
  • Loopback1                      100.100.252.250 YES manual up                    up
  • Loopback2                      100.100.253.250 YES manual up                   up

R9 EIGRP (we are routing for every network and so is BB3)

  • R9#sh run | se router
  • router eigrp 666
  •  network 0.0.0.0
  •  no auto-summary

We need to find out why we are not getting any route from BB3 , remember on the exam you will not be allowed to log on to any of the BB routers , so how do we do this ?

Let’s first create an access list specific for eigrp so in a debug we can only see eigrp packets

  • R9(config)#access-list 101 permit ip any host 224.0.0.10
  • R9(config)#do debug ip packet det 101
  • IP packet debugging is on (detailed) for access list 101
  • R9(config)#
  • *Mar  4 01:10:12.593: IP: s=150.100.69.9 (local), d=224.0.0.10 (Serial1/2), len 60, sending broad/multicast, proto=88
  • R9(config)#
  • *Mar  4 01:10:13.797: IP: s=100.100.250.9 (local), d=224.0.0.10 (FastEthernet0/0), len 60, sending broad/multicast, proto=88
  • *Mar  4 01:10:13.897: IP: s=150.100.91.9 (local), d=224.0.0.10 (FastEthernet0/1), len 60, sending broad/multicast, proto=88
  • R9(config)#
  • *Mar  4 01:10:15.193: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88

So it looks like we are sending and receive packets out/in interaface 0/0 , why are we not getting a neighbour relationship knowing also that these 2 routers DO NOT have passive interafces?

Well at least we now know the ip address on the other end 100.100.250.250 (we could accomplish the same without debugging just by ping broadcast 255.255.255.255 on R9)

So let’s recreate our access list

  • R9(config)#no access-list 101 permit ip any host 224.0.0.10
  • R9(config)#access-list 101 permit ip host 100.100.250.250 host 224.0.0.10
  • R9(config)#do debug ip packet det 101
  • IP packet debugging is on (detailed) for access list 101
  • R9(config)#
  • *Mar  4 01:18:51.197: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88
  • R9(config)#
  • *Mar  4 01:18:56.109: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88
  • R9(config)#
  • *Mar  4 01:19:01.005: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88
  • R9(config)#do u all
  • All possible debugging has been turned off

So here’s the trick , we see the information coming in but we don’t know the AS number and it is obvious it is not our own  cause if it was we would have BB3 as a neighbour already

So to figure it out we need to create another eigrp process on R9 but we don’t know what one , so :

  •  R9(config)#do sh run | se router
  • router eigrp 666
  •  network 0.0.0.0
  •  no auto-summary
  • R9(config)#do sh ip int br | ex un
  • Interface                  IP-Address               OK? Method Status                Protocol
  • FastEthernet0/0            100.100.250.9   YES NVRAM  up                    up
  • FastEthernet0/1            150.100.91.9      YES  NVRAM  up                    up
  • Serial1/2                         150.100.69.9      YES  NVRAM  up                    up
  • Loopback0                     200.0.0.9           YES  NVRAM  up                     up
  • R9(config)#router eigrp 666
  • R9(config-router)#no net 0.0.0.0
  • R9(config-router)#network
  • *Mar  4 01:24:58.741: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 666: Neighbor 150.100.69.6 (Serial1/2) is down: interface down
  • R9(config-router)#network 150.100.91.0 0.0.0.255
  • R9(config-router)#network 150.100.69.0 0.0.0.255
  • *Mar  4 01:25:16.233: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 666: Neighbor 150.100.69.6 (Serial1/2) is up: new adjacency
  • R9(config-router)#network 200.0.0.9 0.0.0.0

And let’s create another eigrp process

  • R9(config-router)#router eigrp 100
  • R9(config-router)#network 100.100.250.0 0.0.0.255

Hhmmm , still nothing , we’ve re-established neighbour relationship with R6 which is not an issue in this example but what about BB3 ?

  •  
  • R9(config-router)#do sh ip prot
  • Routing Protocol is “eigrp 666”
  •   Outgoing update filter list for all interfaces is not set
  •   Incoming update filter list for all interfaces is not set
  •   Default networks flagged in outgoing updates
  •   Default networks accepted from incoming updates
  •   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  •   EIGRP maximum hopcount 100
  •   EIGRP maximum metric variance 1
  •   Redistributing: eigrp 666
  •   EIGRP NSF-aware route hold timer is 240s
  •   Automatic network summarization is not in effect
  •   Maximum path: 4
  •   Routing for Networks:
  •     150.100.69.0/24
  •     150.100.91.0/24
  •     200.0.0.9/32
  •   Routing Information Sources:
  •     Gateway         Distance      Last Update
  •     (this router)         90      02:06:28
  •     150.100.69.6          90      00:01:20
  •   Distance: internal 90 external 170
  • Routing Protocol is “eigrp 100”
  •   Outgoing update filter list for all interfaces is not set
  •   Incoming update filter list for all interfaces is not set
  •   Default networks flagged in outgoing updates
  •   Default networks accepted from incoming updates
  •   EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  •   EIGRP maximum hopcount 100
  •   EIGRP maximum metric variance 1
  •   Redistributing: eigrp 100
  •   EIGRP NSF-aware route hold timer is 240s
  •   Automatic network summarization is in effect
  •   Maximum path: 4
  •   Routing for Networks:
  •     100.100.250.0/24
  •   Routing Information Sources:
  •     Gateway         Distance      Last Update
  •   Distance: internal 90 external 170

So we already have our access list set up but what we want to look at is this :

  • R9(config-router)#do debug ip pac det 101 dump
  •  
  • IP packet debugging is on (detailed) (dump) for access list 101
  • R9(config-router)#
  • *Mar  4 01:29:11.873: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88
  • 07A00AC0:                       0100 5E00000A            ..^…
  • 07A00AD0: C2060BE8 00000800 45C0003C 00000000  B..h….E@.<….
  • 07A00AE0: 01587941 6464FAFA E000000A 0205D753  .XyAddzz`…..WS
  • 07A00AF0: 00000000 00000000 00000000 00001779  ……………y
  • 07A00B00: 0001000C 01000100 0000000F 00040008  …………….
  • 07A00B10: 0C040102                             ….
  • R9(config-router)#
  • *Mar  4 01:29:16.341: IP: s=100.100.250.250 (FastEthernet0/0), d=224.0.0.10, len 60, rcvd 2, proto=88
  • 07A014C0:                       0100 5E00000A            ..^…
  • 07A014D0: C2060BE8 00000800 45C0003C 00000000  B..h….E@.<….
  • 07A014E0: 01587941 6464FAFA E000000A 0205D753  .XyAddzz`…..WS
  • 07A014F0: 00000000 00000000 00000000 00001779  ……………y
  • 07A01500: 0001000C 01000100 0000000F 00040008  …………….
  • 07A01510: 0C040102                             ….
  • R9(config-router)#do u all
  • All possible debugging has been turned off
  • You only need to see one output of these command so let’s see and concentrate on 2 most important parts highlited red :
  • E000000A – This is binary is 224.0.0.10 , our multicast address for eigrp
  • 00001779 – This number is the AS number of our incoming packets
  • Get the calculator and do HEX 00001779 , select DEC and you will get 6009
  • So we go back to R9 and do :
  • R9(config-router)#do sh run | se router
  • router eigrp 666
  •  network 150.100.69.0 0.0.0.255
  •  network 150.100.91.0 0.0.0.255
  •  network 200.0.0.9 0.0.0.0
  •  no auto-summary
  • router eigrp 100
  •  network 100.100.250.0 0.0.0.255
  •  auto-summary
  • R9(config-router)#
  • R9(config-router)#no router eigrp 100
  • R9(config)#router eigrp 6009
  • R9(config-router)#network 100.100.250.0 0.0.0.255
  • *Mar  4 01:37:20.741: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 6009: Neighbor 100.100.250.250 (FastEthernet0/0) is up: new adjacency
  • *Mar  4 01:37:21.753: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 6009: Neighbor 100.100.250.250 (FastEthernet0/0) is resync: summary configured
  • IP-EIGRP neighbors for process 6009
  • H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
  •                                             (sec)         (ms)       Cnt Num
  • 0   100.100.250.250         Fa0/0             14 00:00:38   31   200  0  3
  • There you go , neighbour’s up J and we’re also getting some routes J
  • D       100.100.251.0
  •            [90/156160] via 100.100.250.250, 00:00:55, FastEthernet0/0
  • D       100.100.252.0
  •            [90/156160] via 100.100.250.250, 00:00:55, FastEthernet0/0
  • D       100.100.253.0
  •            [90/156160] via 100.100.250.250, 00:00:55, FastEthernet0/0
Advertisements

About ccie4all
Hello, and welcome to the first post of my CCIE blog This blog has got one simple goal and that is to improve our skills in Cisco Networking field so we can become best engineers on a job market. Wordpress Blog https://ccie4all.wordpress.com/ information about the changes made to Gns3 BGP , MPLS and R&S CCIE labs. In order to access and download all provided materials and receive important updates from Gns3 BGP , MPLS and R&S CCIE labs under GNS3 tab in the main header please go ahead and subscribe to https://ccie4all.wordpress.com/ ! All other posts have not been affected and can be accessed at any given time. Enjoy ! Tom

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: